Error when using multiple threads to import/get data from reposity

I am getting
ERROR: unexpected error - unable to open database file
error whenever I try to import/get/pull from a remote. This happens only after a couple of files get already transferred. So I tried the “-j 1” and now all works. This looks to me that maybe the multiple threads fight for database access and depending on timing it fails ? Not 100% sure.

All I can say that in the failure case I can see the database in question and it has all the right permissions. And as I mentioned it does not fail immediately but only after transferring some data.

I tried it with 2 different remotes and get the same result.
Btw a “dvc checkout” from a shared cache works just fine.

DVC version: 2.45.1 (pip)

Platform: Python 3.10.6 on Linux-5.15.0-71-generic-x86_64-with-glibc2.35
dvc_data = 0.40.3
dvc_objects = 0.19.3
dvc_render = 0.2.0
dvc_task = 0.1.11
dvclive = 2.1.0
scmrepo = 0.1.11
http (aiohttp = 3.8.3, aiohttp-retry = 2.8.3),
https (aiohttp = 3.8.3, aiohttp-retry = 2.8.3),
ssh (sshfs = 2023.1.0)
Cache types: hardlink, symlink
Cache directory: ext4 on /dev/md0
Caches: local
Remotes: ssh, ssh
Workspace directory: ext4 on /dev/md0
Repo: dvc, git

Thanx in advance for any advice.