Error on trying to run dvc pipeline

I’m trying to run the training stage of a machine learning pipeline on dvc with the following command(s):

dvc run -n train \ 
-d data/census_clean.csv -d starter/ \ 
-o model/model.joblib -o model/encoder.joblib -o model/lb.joblib \
python starter/

But this throws up the following error everytime and the run fails to start.

Screenshot 2021-11-29 at 10.13.50 AM

I’m not sure where the mistake on my part is - the same error repeats if I try to run without the output commands, and not specifying the params since hyerparameter tuning is not required at this stage. Please let me know what I’m missing.


Hi. Looks like you might be using python 3.9.8, which has a bug in argparser. The solution is to simply use some other python version. Or you could use one of our binary packages (e.g. brew, snap, conda, exe, osxpkg, etc). Please show dvc doctor output so we could confirm that this is indeed what is going on.


Yes you’re right about the Python version

And switching to a different Python version worked, thanks a lot for the help.

1 Like