ERROR: failed to reproduce ‘dvc.yaml’: [Errno 13] Permission denied

Dear community,

please help me what I can do with the following…
I am running dvc repro and get the following error:

ERROR: failed to reproduce ‘dvc.yaml’: [Errno 13] Permission denied: '/mnt/c/Users/michael/projects/deeplearing/.dvc/cache/57/01bf0661ad5b16b5165d9c6042a0cd597’


  • I was running the dvc repro in a console window of VSCode within a WSL environment
  • I am using a conda environment with dvc installed
  • I already tried deleting the .cache directory
  • it looks like this is not a DVC problem, but an OS problem… still hoping for suggestions because the first stage is running successfully (almost identical to the second stage except that the amount of processed files is smaller)

Maybe somebody has a clue what I can try?

My dvc.yaml looks like this:

    cmd: python
    - original_dataset
    - first_dataset
    cmd: python
    - original_dataset
    - second_dataset

dvc doctor output:

DVC version: 2.5.4 (pip)
Platform: Python 3.8.10 on Linux-5.4.72-microsoft-standard-WSL2-x86_64-with-glibc2.17
        http (requests = 2.26.0),
        https (requests = 2.26.0),
        ssh (paramiko = 2.7.2)
Cache types: hardlink, symlink
Cache directory: 9p on C:\
Caches: local
Remotes: ssh
Workspace directory: 9p on C:\
Repo: dvc, git

Thanks all!

Hi @zigex

Can you also share the contents of dvc.lock (at least the entry with md5: 5701bf0661ad5b16b5165d9c6042a0cd597) and the full output of dvc repro -v?

One thing you can try for now is to check your user owns all the files and dirs in .dvc/cache and that files have 775 permissions, and folders 664 (or whatever is appropriate for your setup).


Hello @jorgeorpinel

thank you very much for trying to help me and replying.

Upon your suggestion, I tried to run dvc repro -v and it suddenly worked. I tried on Friday a couple of hours without any success and did not change anything in my code.

If the error message appears again, I will provide the outputs you suggested.

Kind regards!

1 Like

Sounds good. Maybe another process is meddling with your file permissions. Anyway, glad it’s working now. Best