Can't "dvc pull"

Hello, I’ve tried to use dvc with an existing repository. When I do a “dvc pull”, I get the following error:

Authentication successful.

ERROR: unexpected error - : <HttpError 404 when requesting returned “File not found: 1Hn9uNSx3An6bDVe5Di_ki-AbAAbB9G0B”. Details: "[{‘domain’: ‘global’, ‘reason’: ‘notFound’, ‘message’: ‘File not found: 1Hn9uNSx3An6bDVe5Di_ki-AbAAbB9G0B’, ‘locationType’: ‘other’, ‘location’: ‘file’}]”>

Running “dvc doctor” returns the following message:

DVC version: 2.8.2 (osxpkg)

Platform: Python 3.8.12 on macOS-10.16-x86_64-i386-64bit
azure (adlfs = 2021.9.1, knack = 0.8.2, azure-identity = 1.7.0),
gdrive (pydrive2 = 1.10.0),
gs (gcsfs = 2021.10.1),
hdfs (fsspec = 2021.10.1, pyarrow = 5.0.0),
webhdfs (fsspec = 2021.10.1),
http (aiohttp = 3.7.4.post0, aiohttp-retry = 2.4.6),
https (aiohttp = 3.7.4.post0, aiohttp-retry = 2.4.6),
s3 (s3fs = 2021.10.1, boto3 = 1.17.106),
ssh (sshfs = 2021.9.0),
oss (ossfs = 2021.8.0),
webdav (webdav4 = 0.9.3),
webdavs (webdav4 = 0.9.3)

Could anyone help me dealing with this? Much appreciated!

Hi. Is this a personal drive or is it a team drive? It is possible that you are trying to use that folder with an account that doesn’t have access to it.

I guess it is a personal drive (I did not create it, but a team-mate who uses it without problem). I have tried with different accounts (after the owner gave access to them) and the problem persists.

So looks like you have an permission or auth problem, there is some kind of mismatch. I think we’ve seen this before at some point, but I can’t find exact solution at this very moment. But has the best recipes for using gdrive, so maybe you could use one of those as a workaround.