WebDAV error: Server disconnected without sending a response

Good morning,

I experience an issue when I’m pulling a large quantity of data from my remote storage with WebDAV.

The downloading works properly for a while and then, suddenly, it stops with:
ERROR: failed to transfer '801e4353008d32e0fbf25cd8b4591fd2' - Server disconnected without sending a response.: Server disconnected without sending a response.

If I retry it, it restarts where it stopped so I manage to do the full download eventually but it’s not very handy.

I’ve tried to reduce the number of jobs and increase the timeout but in vain.
I’ve tried to use the API to get the stack trace but it’s not helpful as it’s just raise a FileNotFoundError from the cache, and I think the actual issue is with the downloading before.

I suppose it’s not directly linked to DVC but more to the WebDAV underlying library, but by any chance where it comes from, and if some change in the configuration would help with that?

Thanks a lot in advance for your help!