Unable to locate credentials even though I can call awscli directly


I’m getting ‘Unable to locate credentials’ when I run dvc push even though I can run AWS cli commands e.g. ```aws s3 ls s3://some-bucket

I’m wondering if it’s related to permissions on my .aws files. I’m running on If I run Mac OS 10.15

ls -la /path/to/.aws

I get

drwxr-xr-x   5 username  staff   160  5 Aug 09:18 .
drwxr-xr-x+ 90 username  staff  2880  1 Feb 16:22 ..
drwxr-xr-x   3 username  staff    96  5 Aug 09:18 cli
-rw-------@  1 username  staff   542 15 Oct 16:24 config
-rw-------@  1 username  staff   240 21 Jun  2020 credentials

Any suggestions?

I’ve sorted it out - I need to set the absolute path to the .aws directory in .config or .config.local rather than a relative path

1 Like

Hey @braaannigan glad it’s working. So you used dvc remote modify credentialpath? Note that you shouldn’t need to set the credentials path at all in DVC config if aws CLI is configured on your machine: DVC should find the default AWS credentials automatically.

Feel free to check out https://dvc.org/doc/command-reference/remote/add and https://dvc.org/doc/command-reference/remote/modify for these and other details (expand Amazon S3 sections). Cheers

Hi @jorgeorpinel

I was editing the config and config.local files directly.

It was because I was working on 2 machines, so the relative path to credentials was fine on the first machine, but the path expansion meant it didn’t work on the second machine.

I resolved it by adding the absolute credential path on separate config.local files on each machine.