Need help to connect to COS through DVC

I’m unable to connect to COS using DVC and him getting these errors.
“ERROR: unexpected error - The config profile (*********** could not be found” and my config file has Here is my .dvc/config

remote = s3remote
[‘remote “storage”’]
url = gdrive://***************************************
[‘remote “s3remote”’]
url = s3://mystore/path
endpointurl = https://***************.cloud
region = ***geo
profile = ***********************
read_timeout = 300
connect_timeout = 300

Hi albertsunild ! Could you please share some more details? On which command are you encountering the error? And could you share the traceback from running it with the -v flag?

Hi David,
When I use dvc push I’m getting this error.

Does manually running aws cp to the s3remote work?

I’m using IBM cos. Do you want to run aws cp in the terminal and check?

Yes, just to check if your current authentication works through AWS CLI (It should be compatible with IBM COS IBM Cloud Docs) .

The config profile could bot be found error could be related to python - AWS : The config profile (MyName) could not be found - Stack Overflow.

Hi David, I tried dvc push and im getting below error now.

dvc push
ERROR: failed to transfer ‘md5: e8d165937a34a4c62dd31fa1d48f73dd’ - 405, message=‘Method Not Allowed’, url=URL(‘’)
ERROR: failed to push data to the cloud - 1 files failed to upload

Did you manage to try the aws cp command?

Do you have write permissions for the bucket you are using as remote?

yes, David. I have access to the buckets and I’m able to pull the list of items within the bucket using ibmcloud cli. Apart from that I tried to push a file using cli and was able to do.

ibmcloud cos list-objects --region us-geo --bucket cfc-donotdelete-pr-ocvfpu7q1hxwou --region us-geo
Found 9 objects in bucket ‘cfc-donotdelete-pr-ocvfpu7q1hxwou’:

dvc remote list


Hi @albertsunild!
Have you tried doing cp or ls using aws CLI? DVC should be able to work whenever aws commands work. I cannot verify commands conducted via ibmcloud.