DVC Studio - We could not detect a DVC data remote in this repository

Hi folks,

I’m just trying out Studio.
Bitbucket is used for Git and data is in Google Drive. Created a view and was able to connect to Bitbucket.
However, it appears that no remote control is identified. Note that I am able to dvc push and dvc pull from different computers without any problems. Any idea why?


1 Like

Hi @mcosta!
And the same remote is visible when using locally? For example with dvc remote list?

@Paffciu , dvc remote list works as expected. It shows our remote as expected.

Then it seems it might be something with studio, Ill try to summon someone who nows more on that subject.

Hi @mcosta! Thanks for opening a thread!

I just had a look at this functionality in Studio and am also seeing some weirdness with it myself. Am taking some time for further investigation. Will keep you posted!

Hey @mcosta! Just had a look into this: could you please verify if the remote you are trying to configure is marked as the default remote in your DVC repo?

Currently, Studio does not appear to show non-default remotes on the View Settings page.

You can check this with the dvc remote default command:

# If this output is shown, then you do not have a default remote configured.
$ dvc remote default
No default remote set

$ dvc remote default <your-remote>

# Commit and push your changes:
$ git add .dvc/config
$ git commit -m "Added default remote"
$ git push

I hope this fixes your issue, but let me know if this does not help!

NB: This also confused me personally, which is why I posted that I was seeing some weirdness before. I’m filing an issue internally to improve our UX here.

@duijf thanks! That was exactly the issue!

It is not working yet, though. Followed the instructions, created a key in google cloud, added the credentials in DVC Studio settings (in json) and

$ dvc remote modify myremote gdrive_use_service_account true
$ dvc remote modify myremote --local \
             gdrive_service_account_json_file_path path/to/file.json

After that a new issue appeared.

To use service account, set gdrive_service_account_json_file_path, and optionallygdrive_service_account_user_email in DVC config Learn more at <e[36mhttps://man.dvc.org/remote/modify

I have to stop now, but will come back in a few hours.

@mcosta, glad to hear that partially helped!

I tracked down the problem to a bug in Studio. (We pass the credentials you set up in Studio to DVC as user credentials instead of service account credentials).

I am working on a fix for this. Will keep you posted!

Thank you for reporting this and for trying out Studio!

1 Like

@mcosta A fix has been released. Could you check whether it works for you now?

@duijf tried it and have the following error:

Confirm the directory exists and you can access it. 2. Make sure that credentials in ‘.dvc/tmp/gdrive-user-credentials.json’ are correct for this remote e.g. use the gdrive_user_credentials_file config option if you use multiple GDrive remotes with different email accounts. Details

Probably it is something with Google Service account configuration.

@mcosta Could you check if the Google Service account has permissions to access the Drive folder? You can share the folder with the service account by going to Google Drive, clicking “Share” on the folder you want to share and inviting the service account by email.

It will look something like this:


@duijf It is working now!

Suggestion: in your instructions emphasise this last step.


@mcosta Awesome! Glad to hear and sorry for the trouble on this one.

Suggestion: in your instructions emphasise this last step.

Agreed! I’ve filed Google Drive: Improve service account instructions · Issue #2561 · iterative/dvc.org · GitHub for this

Again, thanks for trying out Studio! Feel free to reach out to us if you have any other issues / feedback!