Dvc exp list shows nothing, but VS Code extension still shows experiments

I want to remove all the experiments. I removed some experiments using dvc exp remove and there is nothing showing when executing dvc exp list, however there are still experiments which were committed showing in the VS Code extension, how can I remove them as well?

1 Like

Hi @SnailTheSnail , could you elaborate on what you mean by:

however there are still experiments which were committed showing

Do you mean that you are seeing previous commits in the table and would like to hide them?
Could you perhaps share a screenshot?

There are still 23 experiments displaying in the extension and dvc exp list is empty.

@SnailTheSnail what does dvc exp show -n 3 return?

1 Like

and also dvc exp list -n 3? I think the default behaviour of exp list is to show only the experiments for the most recent commit.

If you want to get rid of all previous experiments take a look at exp gc. The extension exposes a UI for this command.

dvc exp show -n 3 returns workspace and last 3 experiments, dvc exp list -n 3 returns nothing.
I am unable to remove those previous experiments with dvc exp gc - I tried all the possible options of this command, including the date one and they all return No experiments to remove.

Thanks for the image and details @SnailTheSnail! Those are actually your commit history (it should look similar to what you get from git log). If you had additional experiments, the commits would be expandable like in the image below.

So is there any way to hide/delete them from the experiments tab?

Yes, you should see an option at the bottom of the table to show more or less commits.